Installing the Datasmith Plugin for Archicad on a Mac

Install the Datasmith Exporter plugin for Archicad on a Mac.

Windows
MacOS
Linux

This page explains how to install and remove the Datasmith Exporter plugin for Archicad on a Mac.

Installing the Plugin

Before installing the plugin, remove any previous version of the Datasmith plugin that is installed.

Graphisoft provides their own Datasmith Exporter plugin for Archicad. It is recommended to remove the Graphisoft plugin before installing the Twinmotion Datasmith Exporter plugin.

  1. Download the Datasmith Exporter plugin for Archicad from the Twinmotion website.

  2. Go to the location on your machine where the file was downloaded and double-click the UnrealDatasmithArchicadExporter_Mac_xx.zip file.

    Four plugin files for Archicad 23, 24, 25, and 26 are extracted in the UnrealDatasmithArchicadExporter_Mac_xx folder that is created:

    • DatasmithARCHICAD23Exporter.bundle

    • DatasmithARCHICAD24Exporter.bundle

    • DatasmithARCHICAD25Exporter.bundle

    • DatasmithARCHICAD26Exporter.bundle

  3. Open Archicad.

  4. Create a new project or open an existing project.

  5. In the menu go to Options > Add-On Manager.

    opening-the-add-on-manager.png

  6. In the Add-On Manager, click the EDIT LIST OF AVAILABLE ADD-ONS header and then click the Add button.

    archicad-addon-manager.png

  7. Go to the folder on your machine where the plugin files are located and select the version that you want to install.

    archicad-select-file-mac.png

  8. Click OK.

    In the Add-On Manager, the Datasmith for ARCHICAD plugin is added to the list under AVAILABLE ADD-ONS.

    archicad-installed.png

  9. Click OK to close the Add-On Manager.

    The Add-On Manager Close Warning window appears.

    archicad-close-warning.png

  10. Click the Save Changes and Reload Project button.

    Archicad automatically closes and reopens, and the plugin will be installed.

To show or hide the Datasmith toolbar (palette) in Archicad, on the menu go to Window > Palettes > Datasmith.

archicad-toolbar-mac.png

Removing the Plugin

  1. Open Archicad.

  2. Create a new project or open an existing project.

  3. In the menu go to Options > Add-On Manager.

    opening-the-add-on-manager.png

  4. In the Add-On Manager under AVAILABLE ADD-ONS, remove the check in the Datasmith for Archicad checkbox.

    archicad-checkbox.png

  5. Under EDIT LIST OF AVAILABLE ADD-ONS, click the Remove button.

  6. Click OK to close the Add-On Manager.

  7. The Add-On Manager Close Warning window appears.

    archicad-close-warning.png

  8. Click the Save Changes and Reload Project button.

    Archicad automatically closes and reopens, and the plugin will be removed.

Help shape the future of Unreal Engine documentation! Tell us how we're doing so we can serve you better.
Take our survey
Dismiss